Intermittent Site Outages
Incident Report for connect.wdc.com
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 26, 2018 - 17:21 PDT
Identified
Due to very high user activity, Connect is experiencing a temporary performance issue. The site may be intermittently slow or inaccessible. Our IT team is working with Aurea to resolve the issue and stabilize Connect as soon as possible.
Posted 5 months ago. Jul 26, 2018 - 16:46 PDT
This incident affected: Connect Status.