Connect testing for outage notification
Incident Report for connect.wdc.com
Resolved
The system is up, running and stable now. Thanks for your patience.
Posted 6 months ago. Apr 12, 2018 - 12:51 PDT
Identified
We know what happened! We need to restart the servers. ETA is one hour
Posted 6 months ago. Apr 12, 2018 - 12:50 PDT
Investigating
We are testing the monitoring system
Posted 6 months ago. Apr 12, 2018 - 12:43 PDT